aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-10-23 20:36:10 +0800
committerEfraim Flashner <efraim@flashner.co.il>2023-11-12 08:49:45 +0200
commit15d90e7bfb5df86e0f0104614624d46b53f05858 (patch)
treeb17b1478dc3b37126bccc6c298f9f5a4ffc4698f /gnu/packages/llvm.scm
parentf7411e283a69621fb8240c3c22fdc4a6dcee8530 (diff)
downloadguix-15d90e7bfb5df86e0f0104614624d46b53f05858.tar
guix-15d90e7bfb5df86e0f0104614624d46b53f05858.tar.gz
gnu: clang-runtime-from-llvm: Add phase for LLVM monorepo.
* gnu/packages/llvm.scm (clang-runtime-from-llvm)[arguments]<#:phases>: Change directory to "compiler-rt" for LLVM monorepo. (clang-runtime-15,clang-runtime-14): Adjust accordingly. Change-Id: I6a77c9d106439e4794b8531e2160e2c9ce63d86e
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm27
1 files changed, 7 insertions, 20 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 89b28aef9c..e1e628858b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -161,6 +161,11 @@ as \"x86_64-linux\"."
(ice-9 match)
,@%cmake-build-system-modules)
#:phases (modify-phases (@ (guix build cmake-build-system) %standard-phases)
+ ,@(if hash
+ '()
+ '((add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "compiler-rt")))))
(add-after 'set-paths 'hide-glibc
;; Work around https://issues.guix.info/issue/36882. We need to
;; remove glibc from CPLUS_INCLUDE_PATH so that the one hardcoded
@@ -714,28 +719,10 @@ of programming tools as well as libraries with equivalent functionality.")
("perl" ,perl)))))
(define-public clang-runtime-15
- (let ((template (clang-runtime-from-llvm llvm-15)))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:phases phases '(@ (guix build cmake-build-system) %standard-phases))
- #~(modify-phases #$phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "compiler-rt"))))))))))
+ (clang-runtime-from-llvm llvm-15))
(define-public clang-runtime-14
- (let ((template (clang-runtime-from-llvm llvm-14)))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:phases phases '(@ (guix build cmake-build-system) %standard-phases))
- #~(modify-phases #$phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "compiler-rt"))))))))))
+ (clang-runtime-from-llvm llvm-14))
(define-public clang-15
(clang-from-llvm