aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-07-24 21:05:38 -0400
committerLudovic Courtès <ludo@gnu.org>2016-07-25 10:48:49 +0200
commit60474cd1148e04423318b0724752729199fdec80 (patch)
tree813693375f994948b1ffe7de587c77291d4459e1 /gnu/packages/lisp.scm
parente0524511ec6b8fd1587ffe953db5ee753c73ff92 (diff)
downloadguix-60474cd1148e04423318b0724752729199fdec80.tar
guix-60474cd1148e04423318b0724752729199fdec80.tar.gz
gnu: ecl: Enable tests.
* gnu/packages/lisp.scm (ecl): Enable tests. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm33
1 files changed, 9 insertions, 24 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4dc702f329..ece35114ea 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -119,30 +119,15 @@ interface to the Tk widget system.")
("libgc" ,libgc)
("libffi" ,libffi)))
(arguments
- '(;; During 'make check', ECL fails to initialize with "protocol not
- ;; supported", presumably because /etc/protocols is missing in the
- ;; build environment. See <http://sourceforge.net/p/ecls/bugs/300/>.
- ;;
- ;; Should the test suite be re-enabled, it might be necessary to add
- ;; '#:parallel-tests #f'. See the same bug report as above.
- ;;
- ;; The following might also be necessary, due to 'make check' assuming
- ;; ECL is installed. See <http://sourceforge.net/p/ecls/bugs/299/>.
- ;;
- ;; #:phases
- ;; (let* ((check-phase (assq-ref %standard-phases 'check))
- ;; (rearranged-phases
- ;; (alist-cons-after 'install 'check check-phase
- ;; (alist-delete 'check %standard-phases))))
- ;; (alist-cons-before
- ;; 'check 'pre-check
- ;; (lambda* (#:key outputs #:allow-other-keys)
- ;; (substitute* '("build/tests/Makefile")
- ;; (("ECL=ecl")
- ;; (string-append
- ;; "ECL=" (assoc-ref outputs "out") "/bin/ecl"))))
- ;; rearranged-phases))
- #:tests? #f))
+ '(#:tests? #t
+ #:make-flags `(,(string-append "ECL="
+ (assoc-ref %outputs "out")
+ "/bin/ecl"))
+ #:parallel-tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check (assoc-ref %standard-phases 'check)))))
(home-page "http://ecls.sourceforge.net/")
(synopsis "Embeddable Common Lisp")
(description "ECL is an implementation of the Common Lisp language as