aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-01-09 22:46:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-01-09 23:11:57 +0200
commit513dc568ca36d065f618f06c677db6d82240e9ff (patch)
tree91f4a373163794d73df5ba7d19a17f3690f6ee76 /gnu/packages/linux.scm
parent68b9be1fd8c2f0377f1f41651e3243bbc39120e5 (diff)
downloadguix-513dc568ca36d065f618f06c677db6d82240e9ff.tar
guix-513dc568ca36d065f618f06c677db6d82240e9ff.tar.gz
gnu: iucode-tool: Limit to Intel compatible architectures.
* gnu/packages/linux.scm (iucode-tool)[supported-systems]: New field.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb5e1ccbbb..08498d5d13 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
@@ -2445,6 +2445,8 @@ It works with most newer systems.")
"@command{iucode_tool} is a utility to work with microcode packages for
Intel processors. It can convert between formats, extract specific versions,
create a firmware image suitable for the Linux kernel, and more.")
+ ;; cpuid.h is available for i686, x86_64, and ia64.
+ (supported-systems '("i686-linux" "x86_64-linux"))
(license license:gpl2+)))
(define-public i2c-tools