aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-05 13:21:45 -0500
committerLeo Famulari <leo@famulari.name>2021-02-06 22:17:16 -0500
commit830b0f93f8616f647cecb53b292d064f959012c9 (patch)
tree0429beec9bf7510446362bb89580a4460c65fefd /gnu/packages/linux.scm
parentbf645c7fb158913305a884128131d17bdf29774e (diff)
downloadguix-830b0f93f8616f647cecb53b292d064f959012c9.tar
guix-830b0f93f8616f647cecb53b292d064f959012c9.tar.gz
gnu: linux-libre 4.9: Update to 4.9.256.
* gnu/packages/linux.scm (linux-libre-4.9-version): Update to 4.9.256. (linux-libre-4.9-pristine-source): Update hash. (deblob-scripts-4.9): Use version 4.9.255.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 20ec44d505..787ce0ab85 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -408,15 +408,20 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.14)))
-(define-public linux-libre-4.9-version "4.9.255")
+(define-public linux-libre-4.9-version "4.9.256")
(define deblob-scripts-4.9
(linux-libre-deblob-scripts
- linux-libre-4.9-version
+ ;; 4.9.256 is the same as 4.9.255, but is meant to test if anything
+ ;; breaks when the minor version overflows an 8-bit representation.
+ ;; Same story for 4.4.256.
+ ;; https://lwn.net/Articles/845206/
+ ;; http://kroah.com/log/blog/2021/02/05/8-bits-are-enough-for-a-version-number-dot-dot-dot/
+ "4.9.255"
(base32 "1wvldzlv7q2xdbadas87dh593nxr4a8p5n0f8zpm72lja6w18hmg")
(base32 "0fxajshb75siq39lj5h8xvhdj8lcmddkslwlyj65rhlwk6g2r4b2")))
(define-public linux-libre-4.9-pristine-source
(let ((version linux-libre-4.9-version)
- (hash (base32 "066101fzq5lr1pznw1hwlvsdgqpv8n7b2yi09qpv3xi0r41jvpxg")))
+ (hash (base32 "15qlv4m56dzv195xjy4yp8qsrkbmv51vwfg0qcm664hkrb4i32y4")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.9)))