aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-25 21:59:09 -0500
committerLeo Famulari <leo@famulari.name>2017-02-26 11:39:09 -0500
commitf0a01af5c6e297f9068e4f359488e9fd0417fad2 (patch)
tree56e3854fabb018fcef761b010a512fcfdfe9a76d /gnu/packages/linux.scm
parent378618640da836d5a892f48ad64dda8465652127 (diff)
downloadguix-f0a01af5c6e297f9068e4f359488e9fd0417fad2.tar
guix-f0a01af5c6e297f9068e4f359488e9fd0417fad2.tar.gz
gnu: eudev: Fix build failure caused by conflicting function type declaration.
* gnu/packages/patches/eudev-conflicting-declaration.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/linux.scm (eudev)[source]: Use it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b3fd9d2601..fe72f98b78 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1741,7 +1741,8 @@ from the module-init-tools project.")
(sha256
(base32
"06gyyl90n85x8i7lfhns514y1kg1ians13l467admyzy3kjxkqsp"))
- (patches (search-patches "eudev-rules-directory.patch"))))
+ (patches (search-patches "eudev-rules-directory.patch"
+ "eudev-conflicting-declaration.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)