aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-02-20 00:26:59 -0500
committerMark H Weaver <mhw@netris.org>2017-02-20 03:04:35 -0500
commit52d901da0ca671c9cc79467c554ec5144e14e3fc (patch)
tree2d5f81db1abc006d456bdd9c24c0ed173773e926 /gnu/packages/linux.scm
parent361d982ce36591fad86e0da8d5dca16ff8ed098d (diff)
downloadguix-52d901da0ca671c9cc79467c554ec5144e14e3fc.tar
guix-52d901da0ca671c9cc79467c554ec5144e14e3fc.tar.gz
gnu: linux-libre: Update to 4.10. Keep 4.9 as longterm release.
* gnu/packages/linux.scm (%linux-libre-version): Update to 4.10. (%linux-libre-hash): Update hash. (linux-libre-4.9): New variable. * gnu/packages/linux-libre-4.10-x86_64.conf, gnu/packages/linux-libre-4.10-i686.conf: New files. * Makefile.am (KCONFIGS): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9212b40a1c..cdeb8e92c7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -338,8 +338,8 @@ It has been modified to remove all non-free binary blobs.")
(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
-(define %linux-libre-version "4.9.11")
-(define %linux-libre-hash "1gypfg2984zr4z7hihnl3bbpxnk1mrqbynb6xd8ad2v2z04aw13q")
+(define %linux-libre-version "4.10")
+(define %linux-libre-hash "167zzgkivpqsp07did25wjqsswddzp3gifcdkq7xk00llxlmspla")
(define-public linux-libre
(make-linux-libre %linux-libre-version
@@ -347,6 +347,12 @@ It has been modified to remove all non-free binary blobs.")
%intel-compatible-systems
#:configuration-file kernel-config))
+(define-public linux-libre-4.9
+ (make-linux-libre "4.9.11"
+ "1gypfg2984zr4z7hihnl3bbpxnk1mrqbynb6xd8ad2v2z04aw13q"
+ %intel-compatible-systems
+ #:configuration-file kernel-config))
+
(define-public linux-libre-4.4
(make-linux-libre "4.4.50"
"0c157kk0vgrb1fsyy4q3czqdg4npgql82n6p303afy8ylh2w6d3l"