aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-30 04:02:34 -0500
committerLeo Famulari <leo@famulari.name>2018-02-01 15:50:25 -0500
commiteb096cdebab56680375b26069ec524ddec60267e (patch)
tree45ec60848e2861e2ec1d3d4936dd134dc6c1c763 /gnu/packages/libreoffice.scm
parent04941fc550431a551ec377ed71d7d040712a4fb5 (diff)
downloadguix-eb096cdebab56680375b26069ec524ddec60267e.tar
guix-eb096cdebab56680375b26069ec524ddec60267e.tar.gz
gnu: libreoffice: Fix build with Poppler >= 0.62.0.
* gnu/packages/libreoffice.scm (libreoffice)[arguments]: Patch header and function names in 'prepare-src' phase.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 799b062439..3c04ba8c49 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -946,6 +946,12 @@ and to return information on pronunciations, meanings and synonyms.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((xmlsec (assoc-ref inputs "xmlsec-src")))
(substitute*
+ "sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx"
+ ;; This header was renamed in Poppler 0.62.0.
+ (("UTF8.h") "UnicodeMapFuncs.h")
+ ;; And mapUCS2() was renamed to mapUTF16().
+ (("UCS2") "UTF16"))
+ (substitute*
(list "sysui/CustomTarget_share.mk"
"solenv/gbuild/gbuild.mk"
"solenv/gbuild/platform/unxgcc.mk")