aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-03-27 20:16:19 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-03-27 20:16:19 +0200
commit22e52dbd06726261e370e9b761e7f3a3f6b47630 (patch)
tree1bbb29db3d33c9253b83db5fbef40162a1fd277a /gnu/packages/libreoffice.scm
parentcb386439245d09e52893a4b11f625cb17539e2eb (diff)
downloadguix-22e52dbd06726261e370e9b761e7f3a3f6b47630.tar
guix-22e52dbd06726261e370e9b761e7f3a3f6b47630.tar.gz
gnu: Add libstaroffice.
* gnu/packages/libreoffice.scm (libstaroffice): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a8565af587..a558d8e19e 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -601,6 +601,29 @@ text documents (MacWrite, ClarisWorks, ... ) and for some graphics and
spreadsheet documents.")
(license (list mpl2.0 lgpl2.1+)))) ; dual license
+(define-public libstaroffice
+ (package
+ (name "libstaroffice")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fosnola/libstaroffice/releases/download/"
+ version "/libstaroffice-" version ".tar.xz"))
+ (sha256 (base32
+ "1ii2wi3wr5npyz9gby1bjk8r4wyflpfpc6gx7mmqkhsc9c8frpmy"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/fosnola/libstaroffice")
+ (synopsis "Provides LibreOffice support for old StarOffice documents")
+ (description "@code{libstaroffice} is an import filter for the document formats
+from the old StarOffice (.sdc, .sdw, ...).")
+ (license (list mpl2.0 lgpl2.1+)))) ; dual license
+
(define-public libwps
(package
(name "libwps")