aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-22 18:57:40 -0400
committerLeo Famulari <leo@famulari.name>2016-07-22 18:58:31 -0400
commitd227260d2f7833b6bdc55b8e3792378626ef3b69 (patch)
tree26d47d5d8ee8efb102323bca215429a8f8fe1095 /gnu/packages/libreoffice.scm
parentd778fa5ff6f4a860919eaf13db3f84cfc68cbee8 (diff)
parent26ad4adb5568c6ff370f446431b079520fb09615 (diff)
downloadguix-d227260d2f7833b6bdc55b8e3792378626ef3b69.tar
guix-d227260d2f7833b6bdc55b8e3792378626ef3b69.tar.gz
Merge branch 'master' into core-updates
Resolved conflicts: * gnu/packages/scheme.scm: Conflict in import of (guix licenses). On master, "#:hide (openssl)" was used. On core-updates, "#:select (some licenses)" was used. The latter won the conflict. * gnu/packages/version-control.scm (git)[arguments]: Whitespace conflict in 'install-shell-completion.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 18606f96a1..8f4a6c9f61 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -127,7 +127,7 @@ CSV, CSS and XML.")
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
- version ".tar.xz"))
+ version "/" name "-" version ".tar.xz"))
(sha256 (base32
"03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
(build-system gnu-build-system)
@@ -158,8 +158,8 @@ spreadsheets and presentations.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
- version ".tar.xz"))
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ name "-" version "/" name "-" version ".tar.xz"))
(sha256 (base32
"0b6krzr6kxzm89g6bapn805kdayq70hn16n5b5wfs2lwrf0ag2wx"))))
(build-system gnu-build-system)
@@ -220,8 +220,8 @@ ZVR (simple compressed text format).")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
- version ".tar.xz"))
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ name "-" version "/" name "-" version ".tar.xz"))
(sha256 (base32
"097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
(build-system gnu-build-system)
@@ -576,8 +576,8 @@ text documents, vector drawings, presentations and spreadsheets.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/" name "/" name "/"
- name "-" version ".tar.xz"))
+ (uri (string-append "mirror://sourceforge/" name "/" name "/" name "-"
+ version "/" name "-" version ".tar.xz"))
(sha256 (base32
"1vx9h419fcfcs0yj071hsg9d2qvkacgca6052m8hv3h743cdmzil"))))
(build-system gnu-build-system)
@@ -607,7 +607,7 @@ spreadsheet documents.")
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
- name "-" version ".tar.xz"))
+ name "-" version "/" name "-" version ".tar.xz"))
(sha256 (base32
"0nlrdk7di015l0sk0ivjdqs86zdcvf73p9z9s9ry5glyhrknzxjk"))))
(build-system gnu-build-system)
@@ -635,7 +635,7 @@ Works word processor file format.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/" name "/"
+ (uri (string-append "mirror://sourceforge/" name "/Hunspell/" version "/"
name "-" version ".tar.gz"))
(sha256 (base32
"0v14ff9s37vkh45diaddndcrj0hmn67arh8xh8k79q9c1vgc1cm7"))))
@@ -655,7 +655,8 @@ word compounding or character encoding.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/hunspell/"
+ (uri (string-append "mirror://sourceforge/hunspell/Hyphen/"
+ (version-major+minor version) "/"
name "-" version ".tar.gz"))
(sha256 (base32
"01ap9pr6zzzbp4ky0vy7i1983fwyqy27pl0ld55s30fdxka3ciih"))))
@@ -676,7 +677,7 @@ patterns, which are pre-processed by a perl script.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/hunspell/"
+ (uri (string-append "mirror://sourceforge/hunspell/MyThes/" version "/"
name "-" version ".tar.gz"))
(sha256 (base32
"0prh19wy1c74kmzkkavm9qslk99gz8h8wmjvwzjc6lf8v2az708y"))))