aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-11 16:19:25 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-11 16:33:50 +0100
commit66a30a3ea47ef1086d1b924ebe1d7c6bba8ee72f (patch)
tree8976e710167572a07df6f702329eedc0e4ecb056 /gnu/packages/libevent.scm
parent6a25e59514f590aa541ec35ba36fd36b2a1dcbc3 (diff)
downloadguix-66a30a3ea47ef1086d1b924ebe1d7c6bba8ee72f.tar
guix-66a30a3ea47ef1086d1b924ebe1d7c6bba8ee72f.tar.gz
gnu: libevent: Update to 2.0.22 [fixes CVE-2015-6525].
* gnu/packages/libevent.scm (libevent): Update to 2.0.22.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 752963077b..b4c9c0ce5e 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;;
@@ -32,16 +32,15 @@
(define-public libevent
(package
(name "libevent")
- (version "2.0.21")
+ (version "2.0.22")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/downloads/libevent/libevent/libevent-"
- version
- "-stable.tar.gz"))
+ "https://github.com/libevent/libevent/releases/download/release-"
+ version "-stable/libevent-" version "-stable.tar.gz"))
(sha256
(base32
- "1xblymln9vihdmf1aqkp8chwvnhpdch3786bh30bj75slnl31992"))
+ "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
(patches (list (search-patch "libevent-dns-tests.patch")))))
(build-system gnu-build-system)
(inputs