aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libapr.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-05 14:59:46 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-05 15:12:50 +0200
commit2b24faa295972e839d0ec540375eb74955264feb (patch)
treef3a793081821054c87d52c7281ba807322cc963d /gnu/packages/libapr.scm
parent75c6fd43ed7d6658aa4a04e92250a88e2bddda47 (diff)
downloadguix-2b24faa295972e839d0ec540375eb74955264feb.tar
guix-2b24faa295972e839d0ec540375eb74955264feb.tar.gz
gnu: Rename "libapr" to "apr" and "libaprutil" to "apr-util".
* gnu/packages/apr.scm: Rename file from libapr.scm. * gnu/packages/patches/apr-skip-getservbyname-test.patch: Rename file from libapr-skip-getservbyname-test.patch. * gnu-system.am (GNU_SYSTEM_MODULES): Rename module libapr to apr. * gnu-system.am (dist_patch_DATA): Rename patch file. * gnu/packages/apr.scm (apr): Rename from libapr. * gnu/packages/apr.scm (apr-util): Rename from libaprutil, change input name. * gnu/packages/version-control.scm (subversion): Change input name.
Diffstat (limited to 'gnu/packages/libapr.scm')
-rw-r--r--gnu/packages/libapr.scm91
1 files changed, 0 insertions, 91 deletions
diff --git a/gnu/packages/libapr.scm b/gnu/packages/libapr.scm
deleted file mode 100644
index 9ace167806..0000000000
--- a/gnu/packages/libapr.scm
+++ /dev/null
@@ -1,91 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libapr)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages autotools))
-
-(define-public libapr
- (package
- (name "libapr")
- (version "1.4.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://apache/apr/apr-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0884csfk3f530yscak0jlr6w929s3ys0n7fpwdg3dii1sgwd5f31"))))
- (build-system gnu-build-system)
- (arguments
- `(#:patches (list (assoc-ref %build-inputs
- "patch/skip-test"))
- #:patch-flags '("-p0")))
- (inputs `(("perl" ,perl)
- ("libtool" ,libtool)
- ("patch/skip-test"
- ,(search-patch "libapr-skip-getservbyname-test.patch"))))
- (home-page "http://apr.apache.org/")
- (synopsis "The Apache Portable Runtime Library")
- (description
- "The mission of the Apache Portable Runtime (APR) project is to create and
-maintain software libraries that provide a predictable and consistent interface
-to underlying platform-specific implementations. The primary goal is to provide
-an API to which software developers may code and be assured of predictable if
-not identical behaviour regardless of the platform on which their software is
-built, relieving them of the need to code special-case conditions to work
-around or take advantage of platform-specific deficiencies or features.")
- (license asl2.0)))
-
-(define-public libaprutil
- (package
- (name "libaprutil")
- (version "1.5.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://apache/apr/apr-util-"
- version ".tar.bz2"))
- (sha256
- (base32
- "19qjxpckb9p4j9pbk8kcirg6k5vqnjrqhnk9xx2c5m9964p3vkls"))))
- (build-system gnu-build-system)
- (inputs
- `(("libapr" ,libapr)))
- (arguments
- '(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (libapr (assoc-ref inputs "libapr")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-apr=" libapr)))))
- %standard-phases)))
- (home-page "http://apr.apache.org/")
- (synopsis "One of the Apache Portable Runtime Library companions")
- (description
- "APR-util provides a number of helpful abstractions on top of APR.")
- (license asl2.0)))