aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-16 23:13:17 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-17 13:03:50 -0500
commit57ff0e04f18a253604a65d1e20128de2dff1dddd (patch)
tree3b68881a4a876d1754ca803222ea57f2e8f768d3 /gnu/packages/language.scm
parent0c32bf01172118967d8a7a349313c4b4b06c0012 (diff)
downloadguix-57ff0e04f18a253604a65d1e20128de2dff1dddd.tar
guix-57ff0e04f18a253604a65d1e20128de2dff1dddd.tar.gz
gnu: Add Lingua-EN-Inflect.
* gnu/packages/language.scm (perl-lingua-en-inflect): New variable.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 24e7fa447c..c02771d12a 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -45,6 +45,28 @@ numbers in English text. It also provides functions for extracting and
manipulating such numbers.")
(license (package-license perl))))
+(define-public perl-lingua-en-inflect
+ (package
+ (name "perl-lingua-en-inflect")
+ (version "1.895")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DC/DCONWAY/"
+ "Lingua-EN-Inflect-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0drzg9a2dkjxgf00n6jg0jzhd8972bh3j4wdnmdxpqi3zmfqhwcy"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect")
+ (synopsis "Convert singular to plural")
+ (description "Lingua::EN::Inflect provides plural inflections,
+\"a\"/\"an\" selection for English words, and manipulation of numbers as
+words. Plural forms of all nouns, most verbs, and some adjectives are
+provided. Where appropriate, \"classical\" variants (for example: \"brother\"
+-> \"brethren\", \"dogma\" -> \"dogmata\", etc.) are also provided.")
+ (license (package-license perl))))
+
(define-public perl-lingua-en-words2nums
(package
(name "perl-lingua-en-words2nums")