aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-16 09:04:52 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-16 09:04:52 +0200
commit8b32a70b239b608638bd98f536eb05baa6b740f9 (patch)
treeb7d3ac909c20ef887a63951d10482f4e464971f6 /gnu/packages/kde.scm
parent10db1e6c36616e6422f09548192383feda32e673 (diff)
downloadguix-8b32a70b239b608638bd98f536eb05baa6b740f9.tar
guix-8b32a70b239b608638bd98f536eb05baa6b740f9.tar.gz
gnu: Add attica.
* gnu/packages/kde.scm (attica): New variable.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 0a71329c99..4d75ea76b4 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -130,3 +130,27 @@ while JSON objects are mapped to QVariantMap.")
protocol. The DBusMenu protocol makes it possible for applications to export
and import their menus over DBus.")
(license lgpl2.0+)))
+
+(define-public attica
+ (package
+ (name "attica")
+ (version "0.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.kde.org/stable/"
+ name "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1y74gsyzi70dfr9d1f1b08k130rm3jaibsppg8dv5h3211vm771v"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("qt" ,qt-4)))
+ (home-page "https://projects.kde.org/projects/kdesupport/attica")
+ (synopsis "Qt library for the Open Collaboration Services API")
+ (description "Attica is a Qt library that implements the Open
+Collaboration Services API version 1.6. It grants easy access to the
+services such as querying information about persons and contents. The
+library is used in KNewStuff3 as content provider. In order to integrate
+with KDE's Plasma Desktop, a platform plugin exists in kdebase.")
+ (license lgpl2.1+)))