aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-12 13:16:45 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-18 19:17:11 +0100
commitd3f1ef380cee870a7ae5b4f3aee5fad94cb5ad07 (patch)
tree7aea5f3d4035a796d3455e29e722f8e2b804586b /gnu/packages/kde-frameworks.scm
parentc4c059ef3fe2914f67db90230c02dcb24a94a054 (diff)
downloadguix-d3f1ef380cee870a7ae5b4f3aee5fad94cb5ad07.tar
guix-d3f1ef380cee870a7ae5b4f3aee5fad94cb5ad07.tar.gz
gnu: breeze: Split from breeze-icons.
KDE breeze is separate from breeze-icons, as it can bee seen by version, download path and git repository path being all different. Thus a package containing both beeze and the breeze-icons contradicts with this upstream separation. * gnu/package/kde.scm (breeze-assets): Remove variable. (breeze): Move to ... * gnu/package/kde-plasme.scm (breeze): here. [version, source]: Copy from former breeze-assets. [build-system]: Make explicit (was inherited even from breeze-icons). [arguments]: Remove. [native-inputs]: New element. [inputs]: Copy from former breeze-assets; add some optional packages. [home-page]: Fix and change to invent.kde.org. [snopysis, description]: Adjust to de-unified package. [licence]: Remove gpl3+, which came from breeze-icons.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c5a36c7874..9ecbf75d34 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -327,63 +327,6 @@ It is the default icon theme for the KDE Plasma 5 desktop.")
;; text.
(license license:lgpl3+)))
-(define-public breeze-assets
- (package
- (inherit breeze-icons)
- (name "breeze-assets")
- (version "5.19.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kde/stable/plasma/" version
- "/breeze-" version ".tar.xz"))
- (sha256
- (base32
- "0dpk1w7zcafrzf46j060i1qb0fwqpsflkfzr6gcar81llmjnc4b1"))))
- (inputs
- `(,@(package-inputs breeze-icons)
- ("ki18n" ,ki18n)
- ("kpackage" ,kpackage)
- ("kguiaddons" ,kguiaddons)
- ("kdecoration" ,kdecoration)
- ("kcoreaddons" ,kcoreaddons)
- ("kiconthemes" ,kiconthemes)
- ("kwindowsystem" ,kwindowsystem)
- ("kconfigwidgets" ,kconfigwidgets)
- ("qtx11extras" ,qtx11extras)))
- (home-page "https://github.com/KDE/breeze")
- (synopsis "Artwork, styles and assets for the Breeze visual style")
- (description "This package contains artwork, styles and assets associated
-with the Breeze visual style.")
- (license license:gpl2+)))
-
-(define-public breeze
- (package
- (name "breeze")
- (version (package-version breeze-assets))
- (source #f)
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build union))
- #:builder
- (begin
- (use-modules (ice-9 match)
- (guix build union))
- (match %build-inputs
- (((names . directories) ...)
- (union-build (assoc-ref %outputs "out")
- directories)
- #t)))))
- (inputs
- `(("breeze-icons" ,breeze-icons)
- ("breeze-assets" ,breeze-assets)))
- (home-page "https://github.com/KDE/breeze-icons")
- (synopsis "Full KDE Breeze theme")
- (description
- "This package contains the full Breeze visual style for KDE:
-assets and icons.")
- (license (list license:gpl2 license:gpl3+))))
-
(define-public kapidox
(package
(name "kapidox")