aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-26 12:23:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-26 14:45:58 +0300
commite3ec1258e321c75eb98c3f687b6d62f8d8e21737 (patch)
tree662caee4ebd6d8a75674e76c69777852189fbbeb /gnu/packages/java.scm
parent6e6bd6f92952600e1bddf078daf27000dae8d764 (diff)
downloadguix-e3ec1258e321c75eb98c3f687b6d62f8d8e21737.tar
guix-e3ec1258e321c75eb98c3f687b6d62f8d8e21737.tar.gz
gnu: classpath-jamvm-wrappers: Fix building on armhf-linux.
* gnu/packages/java.scm (classpath-jamvm-wrappers)[arguments]: Change the flags used in custom script for armhf-linux.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c0a7cd756a..c11beff445 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -531,12 +531,20 @@ the standard javac executable.")))
(for-each (lambda (tool)
(with-output-to-file (string-append bin tool)
(lambda _
- (format #t "#!~a/bin/sh
+ ,@(if (string-prefix? "armhf" (or (%current-system)
+ (%current-target-system)))
+ `((format #t "#!~a/bin/sh
+~a/bin/jamvm -Xnocompact -classpath ~a/share/classpath/tools.zip \
+gnu.classpath.tools.~a.~a $@"
+ bash jamvm classpath tool
+ (if (string=? "native2ascii" tool)
+ "Native2ASCII" "Main")))
+ `((format #t "#!~a/bin/sh
~a/bin/jamvm -Xnocompact -Xnoinlining -classpath ~a/share/classpath/tools.zip \
gnu.classpath.tools.~a.~a $@"
bash jamvm classpath tool
(if (string=? "native2ascii" tool)
- "Native2ASCII" "Main"))))
+ "Native2ASCII" "Main"))))))
(chmod (string-append bin tool) #o755))
(list "javah"
"rmic"