aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-04 15:51:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 00:40:14 +0100
commit507809be152049dff26bffdb58e1a90b638f046b (patch)
treef743d7c3faaedaf883df9c611d14427df141a5a2 /gnu/packages/irc.scm
parentbafd5bea97569f82922bfc8c053c1b60d7660604 (diff)
downloadguix-507809be152049dff26bffdb58e1a90b638f046b.tar
guix-507809be152049dff26bffdb58e1a90b638f046b.tar.gz
gnu: weechat: Make sure it finds the correct python.
Fixes <https://bugs.gnu.org/21879>. * gnu/packages/irc.scm (weechat)[arguments]: Drop 'set-python-file-name' phase in favor of a 'wrap' phase.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 82eb103688..1a1f748b4c 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@libertad.pw>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -180,14 +181,13 @@ SILC and ICB protocols via plugins.")
(add-before 'configure 'autogen
(lambda _
(zero? (system* "./autogen.sh"))))
- (add-before 'build 'set-python-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/plugins/python/weechat-python.c"
- (("python2_bin = weechat_python_get_python2_bin.*;")
- (string-append "python2_bin = strdup (\""
- (assoc-ref inputs "python")
- "/bin/python\");\n")))
- #t)))))
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (py2 (assoc-ref inputs "python")))
+ (wrap-program (string-append out "/bin/weechat")
+ `("PATH" ":" prefix (,(string-append py2 "/bin"))))
+ #t))))))
(synopsis "Extensible chat client")
(description "WeeChat (Wee Enhanced Environment for Chat) is an
Internet Relay Chat client, which is designed to be light and fast.