aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 13:40:26 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 22:47:24 -0500
commit618ea7c94effc0cdd9513df01776bff0de8211f6 (patch)
tree0d252743bd969d94e97d6205157be80b248257bd /gnu/packages/inkscape.scm
parentce4d7abf02627e990551c3bf0b67abfdf6725952 (diff)
downloadguix-618ea7c94effc0cdd9513df01776bff0de8211f6.tar
guix-618ea7c94effc0cdd9513df01776bff0de8211f6.tar.gz
gnu: inkscape: Update to 0.48.5.
* gnu/packages/patches/inkscape-stray-comma.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/inkscape.scm (inkscape): Update to 0.48.5. Remove patch. Use the .bz2 source tarball. Use current libgc. Add 'fix-test-includes' phase.
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index b48bedc78d..26513b87be 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,15 +42,14 @@
(define-public inkscape
(package
(name "inkscape")
- (version "0.48.4")
+ (version "0.48.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/inkscape/inkscape-"
- version ".tar.gz"))
+ version ".tar.bz2"))
(sha256
(base32
- "0nhxsgrgsx6zrgpkd1akxjvmdqjp8ccnsvlwxh62l0brg84fw6bf"))
- (patches (list (search-patch "inkscape-stray-comma.patch")))))
+ "0sfr7a1vr1066rrkkqbqvcqs3gawalj68ralnhd6k87jz62fcv1b"))))
(build-system gnu-build-system)
(inputs
`(("aspell" ,aspell)
@@ -60,11 +60,7 @@
("libpng" ,libpng)
("libxml2" ,libxml2)
("libxslt" ,libxslt)
-
- ;; With libgc 7.4, compilation fails with:
- ;; gc.cpp:123:1: error: invalid conversion from 'int (*)(void**, const void*)' to 'int (*)(void**, void*)'
- ("libgc" ,libgc-7.2)
-
+ ("libgc" ,libgc)
("freetype" ,freetype)
("popt" ,popt)
("python" ,python-2)
@@ -74,6 +70,13 @@
`(("intltool" ,intltool)
("perl" ,perl)
("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:phases (alist-cons-after
+ 'unpack 'fix-test-includes
+ (lambda _
+ (substitute* "src/cxxtests.cpp"
+ (("\\.\\./\\.\\./src") "../src")))
+ %standard-phases)))
(home-page "http://inkscape.org/")
(synopsis "Vector graphics editor")
(description "Inkscape is a vector graphics editor. What sets Inkscape