aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/indent.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/indent.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
guix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/indent.scm')
-rw-r--r--gnu/packages/indent.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/indent.scm b/gnu/packages/indent.scm
new file mode 100644
index 0000000000..eb42e6a7b4
--- /dev/null
+++ b/gnu/packages/indent.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages indent)
+ #:use-module (distro)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public indent
+ (package
+ (name "indent")
+ (version "2.2.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/indent/indent-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
+ (build-system gnu-build-system)
+ (synopsis "GNU Indent, a program for code indentation and formatting")
+ (description
+ "GNU Indent can be used to make code easier to read. It can also convert
+from one style of writing C to another. Indent understands a substantial
+amount about the syntax of C, but it also attempts to cope with incomplete
+and misformed syntax. The GNU style of indenting is the default.")
+ (license gpl3+)
+ (home-page "http://www.gnu.org/software/indent/")))