aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-23 14:24:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-23 16:00:04 +0100
commitbbf8832f160120d4f78b563653db49ab715e7c6c (patch)
tree217482b39ebfd4aa03f7810e1cccb18c05a66ddf /gnu/packages/image.scm
parent5a82c904004d6db4bc3b2d294e6dacb5ac0139f8 (diff)
downloadguix-bbf8832f160120d4f78b563653db49ab715e7c6c.tar
guix-bbf8832f160120d4f78b563653db49ab715e7c6c.tar.gz
gnu: optipng: Update to 0.7.7 [security fixes].
This release claims to fix 2 vulnerabilities: - ‘an integer overflow vulnerability in the TIFF decoder’ (CVE-2017-1000229, previously patched in Guix), and - ‘a buffer overflow vulnerability in the GIF decoder’. * gnu/packages/image.scm (optipng): Update to 0.7.7. [source]: Remove patch. [arguments]: Substitute INVOKE for SYSTEM* and end phase with #t. * gnu/packages/patches/optipng-CVE-2017-1000229.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 9052a34e96..93114d8e07 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
@@ -1091,29 +1091,28 @@ installed as @code{stb_image}.")
(define-public optipng
(package
(name "optipng")
- (version "0.7.6")
+ (version "0.7.7")
(source
(origin
(method url-fetch)
(uri (string-append "http://prdownloads.sourceforge.net/optipng/optipng-"
version ".tar.gz"))
- (patches (search-patches "optipng-CVE-2017-1000229.patch"))
(sha256
(base32
- "105yk5qykvhiahzag67gm36s2kplxf6qn5hay02md0nkrcgn6w28"))))
+ "0lj4clb851fzpaq446wgj0sfy922zs5l5misbpwv6w7qrqrz4cjg"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)))
(arguments
'(#:phases
(modify-phases %standard-phases
- ;; configure script does not accept arguments CONFIG_SHELL and SHELL
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "sh" "configure"
- (string-append "--prefix=" (assoc-ref outputs "out")))))))))
- (synopsis "Optimizer that recompresses PNG image files to a
-smaller size")
+ ;; configure script doesn't accept arguments CONFIG_SHELL and SHELL
+ (invoke "sh" "configure"
+ (string-append "--prefix=" (assoc-ref outputs "out")))
+ #t)))))
+ (synopsis "Optimizer that recompresses PNG image files to a smaller size")
(description "OptiPNG is a PNG optimizer that recompresses image
files to a smaller size, without losing any information. This program
also converts external formats (BMP, GIF, PNM and TIFF) to optimized