aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-08 07:59:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-09 16:43:11 +0200
commit910a20e2b8ac6d1c331ff79535831cce6222b3a3 (patch)
treeb8faecfb87ef85e2bfe21e563e1be6c60fbf825f /gnu/packages/image.scm
parenta617fd55df0fbdae951ec82b81ad512436e972ed (diff)
downloadguix-910a20e2b8ac6d1c331ff79535831cce6222b3a3.tar
guix-910a20e2b8ac6d1c331ff79535831cce6222b3a3.tar.gz
gnu: jbig2dec: Replace with 0.15 [security fixes].
* gnu/packages/image.scm (jbig2dec-0.15): New public variable. (jbig2dec)[replacement]: New field.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 81d22ed42d..78fb30c279 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -495,6 +496,7 @@ arithmetic ops.")
(package
(name "jbig2dec")
(version "0.14")
+ (replacement jbig2dec-0.15)
(source
(origin
(method url-fetch)
@@ -519,6 +521,21 @@ work.")
(home-page "https://jbig2dec.com")
(license license:gpl2+)))
+;; This is a bugfix release from an ongoing Ghostscript security audit.
+;; It was released alongside Ghostscript 9.24.
+(define-public jbig2dec-0.15
+ (package
+ (inherit jbig2dec)
+ (version "0.15")
+ (source (origin
+ (inherit (package-source jbig2dec))
+ (uri (string-append "https://github.com/ArtifexSoftware"
+ "/ghostpdl-downloads/releases/download/gs924/"
+ "jbig2dec-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m1qwpbjbirgw2fqznbajdhdhh35d6xa2csr64lpjz735pvimykb"))))))
+
(define-public openjpeg
(package
(name "openjpeg")