aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/idris.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-13 18:09:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-13 18:12:37 +0100
commit44b7374a220caf73e398f156e08887250214cbeb (patch)
treea01b53c46cf6eec4f8538239f95d116b058f3b56 /gnu/packages/idris.scm
parenta06b9b50075a78f846093f86da85d5806b36fbf7 (diff)
downloadguix-44b7374a220caf73e398f156e08887250214cbeb.tar
guix-44b7374a220caf73e398f156e08887250214cbeb.tar.gz
gnu: Move web packages from haskell to haskell-web.
* gnu/packages/haskell.scm (ghc-tagsoup, ghc-cookie, ghc-http-types, ghc-http, ghc-http-client, ghc-http-client-tls, ghc-http-date, ghc-http2, ghc-http-conduit, ghc-wai, ghc-wai-logger, ghc-wai-extra, ghc-wai-conduit, ghc-warp, ghc-warp-tls, ghc-xss-sanitize, ghc-css-text, ghc-mime-types, ghc-html, ghc-xhtml, ghc-blaze-html, ghc-aeson, ghc-aeson-pretty, ghc-aeson-qq, ghc-multipart): Move variables to ... * gnu/packages/haskell-web.scm: ... this new file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/haskell.scm, gnu/packages/idris.scm, gnu/packages/version-control.scm, gnu/packages/wm.scm: Include haskell-web module.
Diffstat (limited to 'gnu/packages/idris.scm')
-rw-r--r--gnu/packages/idris.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 438e582fe3..6eb940c9d5 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -20,6 +20,7 @@
(define-module (gnu packages idris)
#:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-check)
+ #:use-module (gnu packages haskell-web)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (guix build-system gnu)