aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ibus.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-08-25 10:23:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-25 11:09:28 +0200
commit590021db3f3fae35d9773ff8fce59623ad7236cd (patch)
tree75c70ebad96de85b1e3da26d206a718a53032c6d /gnu/packages/ibus.scm
parentd2a7a14572a90c80aec52a6cb389cf6c8e3de71f (diff)
downloadguix-590021db3f3fae35d9773ff8fce59623ad7236cd.tar
guix-590021db3f3fae35d9773ff8fce59623ad7236cd.tar.gz
gnu: ibus: Use modify-phases syntax.
* gnu/packages/ibus.scm (ibus)[arguments]: Use modify-phases syntax.
Diffstat (limited to 'gnu/packages/ibus.scm')
-rw-r--r--gnu/packages/ibus.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index db7d084fc7..bf40b01b4f 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;;
@@ -62,24 +62,23 @@
(assoc-ref %outputs "out")
"/lib/python2.7/site-packages/gi/overrides/"))
#:phases
- (alist-cons-before
- 'configure 'disable-dconf-update
- (lambda _
- (substitute* "data/dconf/Makefile.in"
- (("dconf update") "echo dconf update"))
- #t)
- (alist-cons-after
- 'wrap-program 'wrap-with-additional-paths
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
- ;; GI_TYPELIB_PATH.
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/ibus-setup")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
- `("GI_TYPELIB_PATH" ":" prefix
- (,(getenv "GI_TYPELIB_PATH")
- ,(string-append out "/lib/girepository-1.0"))))))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (add-before 'configure 'disable-dconf-update
+ (lambda _
+ (substitute* "data/dconf/Makefile.in"
+ (("dconf update") "echo dconf update"))
+ #t))
+ (add-after 'wrap-program 'wrap-with-additional-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
+ ;; GI_TYPELIB_PATH.
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/ibus-setup")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH")
+ ,(string-append out "/lib/girepository-1.0")))))
+ #t)))))
(inputs
`(("dbus" ,dbus)
("dconf" ,dconf)