aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-03-13 17:22:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-13 20:01:54 +0100
commitf45c86b555820b4ddfe4705f052eca480da03ae1 (patch)
tree444f3a47703b06f44b4e0ea8a5078dd46298d870 /gnu/packages/haskell.scm
parentdcf8e2ab30afd76754126a54059a60dd7c128e10 (diff)
downloadguix-f45c86b555820b4ddfe4705f052eca480da03ae1.tar
guix-f45c86b555820b4ddfe4705f052eca480da03ae1.tar.gz
gnu: Add ghc-hslua-for-pandoc-1.
* gnu/packages/haskell.scm (ghc-hslua-for-pandoc-1): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3359a196cf..a222e1b4ae 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5703,6 +5703,27 @@ TIFF and GIF formats.")
described in @url{https://www.lua.org/}.")
(license license:expat)))
+(define-public ghc-hslua-for-pandoc-1
+ (package (inherit ghc-hslua)
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hslua/hslua-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gqp6qhp4v24kzv2j49kgk7bxqzw0w10x0zr0r2j9wkfavqb9wid"))))
+ (inputs
+ `(("lua" ,lua-5.1)
+ ("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-hspec-contrib" ,ghc-hspec-contrib)
+ ("ghc-hunit" ,ghc-hunit)
+ ("hspec-discover" ,hspec-discover)))))
+
(define-public ghc-hslua-module-text
(package
(name "ghc-hslua-module-text")