aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:31:52 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitac5d633a960264e6300e492a6cfe8313c8ceddd6 (patch)
tree4ab4d1732c8a02bb680f2f844b0a9ba389ebd705 /gnu/packages/haskell.scm
parent27f39490860dd6bdc4b9c3d0645d75efccdde99c (diff)
downloadguix-ac5d633a960264e6300e492a6cfe8313c8ceddd6.tar
guix-ac5d633a960264e6300e492a6cfe8313c8ceddd6.tar.gz
gnu: Add ghc-hslua.
* gnu/packages/haskell.scm (ghc-hslua): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8006cb69cb..06c1750bba 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libedit)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages python)
@@ -5600,6 +5601,37 @@ been paid to performance, these do not presently reach the speed of well-tuned
libraries, like OpenSSL.")
(license bsd-3)))
+(define-public ghc-hslua
+ (package
+ (name "ghc-hslua")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "hslua/hslua-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gqp6qhp4v24kzv2j49kgk7bxqzw0w10x0zr0r2j9wkfavqb9wid"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags '("-fsystem-lua")))
+ (inputs
+ `(("lua" ,lua-5.1)))
+ (propagated-inputs
+ `(("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hspec-contrib" ,ghc-hspec-contrib)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
+ (home-page "http://hackage.haskell.org/package/hslua")
+ (synopsis "Lua language interpreter embedding in Haskell")
+ (description
+ "The Scripting.Lua module is a wrapper of the Lua language interpreter as
+described in @url{http://www.lua.org/}.")
+ (license expat)))
+
(define-public idris
(package
(name "idris")