aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-03-13 17:22:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-13 20:01:54 +0100
commit6c055278514c1374a4fe6e803ab618bfc797cf58 (patch)
tree7026d300be78ab6a12cdbce5f3330f7572ad702b /gnu/packages/haskell.scm
parentf45c86b555820b4ddfe4705f052eca480da03ae1 (diff)
downloadguix-6c055278514c1374a4fe6e803ab618bfc797cf58.tar
guix-6c055278514c1374a4fe6e803ab618bfc797cf58.tar.gz
gnu: Add ghc-doctemplates-for-pandoc-1.
* gnu/packages/haskell.scm (ghc-doctemplates-for-pandoc-1): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a222e1b4ae..5cee8623f3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5981,6 +5981,29 @@ provided. Skylighting is intended to be the successor to highlighting-kate.")
"This package provides a simple text templating system used by pandoc.")
(license license:bsd-3)))
+(define-public ghc-doctemplates-for-pandoc-1
+ (package (inherit ghc-doctemplates)
+ (version "0.1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "doctemplates/doctemplates-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0swal6rjya1293mwvl63jch5fx9ghpsil7qs4v7rpansa0izalmp"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson-for-pandoc-1)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-text" ,ghc-text)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-scientific" ,ghc-scientific)))))
+
(define-public ghc-pandoc
(package
(name "ghc-pandoc")