aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:32:50 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit51c05fcf206ff5be99026eb2d0cfb5a9e70098c3 (patch)
treed4daf4d8aab526b387e3e0b2519a93a821e548af /gnu/packages/haskell.scm
parentc3cb9fa67cde6e2adaf404e3caacafc9aa628d41 (diff)
downloadguix-51c05fcf206ff5be99026eb2d0cfb5a9e70098c3.tar
guix-51c05fcf206ff5be99026eb2d0cfb5a9e70098c3.tar.gz
gnu: Add ghc-byteable.
* gnu/packages/haskell.scm (ghc-byteable): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fcd4ccb795..2db27a4a3b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5694,6 +5694,26 @@ described in @url{http://www.lua.org/}.")
for more user-friendly packages.")
(license expat)))
+(define-public ghc-byteable
+ (package
+ (name "ghc-byteable")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "byteable/byteable-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qizg0kxxjqnd3cbrjhhidk5pbbciz0pb3z5kzikjjxnnnhk8fr4"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/vincenthz/hs-byteable")
+ (synopsis "Type class for sequence of bytes")
+ (description
+ "This package provides an abstract class to manipulate sequence of bytes.
+The use case of this class is abstracting manipulation of types that are just
+wrapping a bytestring with stronger and more meaniful name.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")