aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-20 12:56:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-20 12:56:14 +0200
commitd15432ca9e9359b865aac63ae47863e94bbce0e4 (patch)
treebe4e6f52cb8e31f5b5fad637c95c0a730ea76081 /gnu/packages/haskell.scm
parentdef971689052ebc3e0a68684328c28cac35b8596 (diff)
parent3b254d76132627ff62ac5571f4175669164624c5 (diff)
downloadguix-d15432ca9e9359b865aac63ae47863e94bbce0e4.tar
guix-d15432ca9e9359b865aac63ae47863e94bbce0e4.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 29 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 37e35c45fd..d0f659f6e3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -33,7 +33,6 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
- #:use-module (gnu packages libedit)
#:use-module (gnu packages libffi)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
@@ -107,7 +106,6 @@
`(("gmp" ,gmp)
("ncurses" ,ncurses)
("libffi" ,libffi)
- ("libedit" ,libedit)
("ghc-testsuite"
,(origin
(method url-fetch)
@@ -286,7 +284,6 @@ interactive environment for the functional language Haskell.")
`(("gmp" ,gmp)
("ncurses" ,ncurses)
("libffi" ,libffi)
- ("libedit" ,libedit)
("ghc-testsuite"
,(origin
(method url-fetch)
@@ -8168,4 +8165,33 @@ Rust syntax. It is intended to be useful for two different purposes:
files in Haskell.")
(license license:bsd-3)))
+(define-public ghc-hslogger
+ (package
+ (name "ghc-hslogger")
+ (version "1.2.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hslogger-" version "/" "hslogger-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0as5gvlh6pi2gflakp695qnlizyyp059dqrhvjl4gjxalja6xjnp"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-network" ,ghc-network)
+ ("ghc-directory", ghc-directory)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-process" ,ghc-process)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://software.complete.org/hslogger")
+ (synopsis "Logging framework for Haskell, similar to Python's logging module")
+ (description "Hslogger lets each log message have a priority and source be
+associated with it. The programmer can then define global handlers that route
+or filter messages based on the priority and source. It also has a syslog
+handler built in.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here