aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:18:26 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit85160205074a3213cfd3168b786a2af5555f13a8 (patch)
tree5fa6df8975239f699e9171c396b708e2e345626c /gnu/packages/haskell.scm
parentc27f3aced3d3d9c109248f8664447a9fba067689 (diff)
downloadguix-85160205074a3213cfd3168b786a2af5555f13a8.tar
guix-85160205074a3213cfd3168b786a2af5555f13a8.tar.gz
gnu: Add ghc-monad-control.
* gnu/packages/haskell.scm (ghc-monad-control): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 935ee441bd..717eef0a12 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1902,6 +1902,32 @@ representing a store for a single element.")
manipulating monad transformer stacks.")
(license bsd-3)))
+(define-public ghc-monad-control
+ (package
+ (name "ghc-monad-control")
+ (version "1.0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/monad-control"
+ "/monad-control-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07pn1p4m80wdd7gw62s4yny8rbvm60ka1q8qx5y1plznd8sbg179"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-stm" ,ghc-stm)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (home-page "https://github.com/basvandijk/monad-control")
+ (synopsis "Monad transformers to lift control operations like exception
+catching")
+ (description "This package defines the type class @code{MonadBaseControl},
+a subset of @code{MonadBase} into which generic control operations such as
+@code{catch} can be lifted from @code{IO} or any other base monad.")
+ (license bsd-3)))
+
(define-public ghc-async
(package
(name "ghc-async")