aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 17:08:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 01:14:03 +0200
commit3499d2369267fd218b29c21844fe3e199fc21770 (patch)
tree8664bbee92e0f880e340ec8b9df75d5b97698fa4 /gnu/packages/haskell-xyz.scm
parentb35adf09e7e1d881b7aba041c7672e20ebf7c8c4 (diff)
downloadguix-3499d2369267fd218b29c21844fe3e199fc21770.tar
guix-3499d2369267fd218b29c21844fe3e199fc21770.tar.gz
gnu: Add ghc-ini.
* gnu/packages/haskell-xyz.scm (ghc-ini): New public variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 087e60fc9a..898cd9b78a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018, 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -6464,6 +6464,30 @@ lines continued at an indented level below.")
license from a given license file.")
(license license:expat)))
+(define-public ghc-ini
+ (package
+ (name "ghc-ini")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "ini/ini-" version ".tar.gz"))
+ (sha256
+ (base32 "0mvwii8jbh2ll54qb9dij5m66c6324s2y4vrwz1qr4wz40m3qa8l"))))
+ (build-system haskell-build-system)
+ (native-inputs `(("ghc-hspec" ,ghc-hspec)))
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (home-page "https://github.com/chrisdone/ini")
+ (synopsis
+ "Haskell library to easily handle configuration files in the INI format")
+ (description
+ "The @code{ghc-ini} Haskell library lets programmers quickly and easily
+read and write configuration files in the simple INI format.")
+ (license license:bsd-3)))
+
(define-public ghc-inline-c
(package
(name "ghc-inline-c")