aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-04-29 11:08:42 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-04-29 11:08:42 +0200
commit4035c3e3525599c3aa958d498c5bc789a4adffc3 (patch)
treee55a02215fcdb635d0504fc129526bfbf66abd14 /gnu/packages/haskell-web.scm
parent492b82bd4d592276e65c4b9bfbe1b679a00ff09f (diff)
parent4f0f46e4af0e342d84c5ad448258702029601e4b (diff)
downloadguix-4035c3e3525599c3aa958d498c5bc789a4adffc3.tar
guix-4035c3e3525599c3aa958d498c5bc789a4adffc3.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm41
1 files changed, 38 insertions, 3 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index acdc1447a4..05be862a85 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -752,6 +752,41 @@ Haskell.")
documents.")
(license license:bsd-3)))
+(define-public ghc-html-conduit
+ (package
+ (name "ghc-html-conduit")
+ (version "1.3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/html-conduit/"
+ "html-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "196c8zcnjp1pc5qvqxd8arx3xkw0a90rvg9mmiw2l4zwnx65709n"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-xml-conduit" ,ghc-xml-conduit)
+ ("ghc-xml-types" ,ghc-xml-types)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/snoyberg/xml")
+ (synopsis "Parse HTML documents using xml-conduit datatypes")
+ (description
+ "This package provides a parser for HTML documents that uses
+tagstream-conduit. It automatically balances mismatched tags, so that
+there shouldn't be any parse failures. It does not handle a full HTML
+document rendering, such as adding missing html and head tags. Note that,
+since version 1.3.1, it uses an inlined copy of tagstream-conduit with
+entity decoding bugfixes applied.")
+ (license license:expat)))
+
(define-public ghc-blaze-html
(package
(name "ghc-blaze-html")
@@ -1094,7 +1129,7 @@ functions, widgets, etc.")
(define-public ghc-yesod-persistent
(package
(name "ghc-yesod-persistent")
- (version "1.6.0.2")
+ (version "1.6.0.4")
(source
(origin
(method url-fetch)
@@ -1103,7 +1138,7 @@ functions, widgets, etc.")
"yesod-persistent-" version ".tar.gz"))
(sha256
(base32
- "17adw0aaj29ia7ii3jka301442860b5wvfrms079q973gzahz5fd"))))
+ "1gsiw2zx6z7za7a164h0fxfggkrdqz6fn0qyb2zn9qr7r2jbg1c0"))))
(build-system haskell-build-system)
(arguments `(#:tests? #f)) ; FIXME: hspec-discover not available in PATH.
(inputs `(("ghc-yesod-core" ,ghc-yesod-core)
@@ -1655,6 +1690,6 @@ non-Haskell dependencies.")
"High level web scraping library for Haskell")
(description
"Scalpel is a web scraping library inspired by libraries like Parsec
-and Perl's @code{Web::Scraper} Scalpel builds on top of TagSoup to provide a
+and Perl's @code{Web::Scraper}. Scalpel builds on top of TagSoup to provide a
declarative and monadic interface.")
(license license:asl2.0)))