aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:24:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commitee448389cd3fb39f0f366bb71c6e9008b95ecb0a (patch)
treecf55752ccab17468374940955ae8bb94db582d0f /gnu/packages/haskell-check.scm
parent4012ea04b41d7441d35c1e5da49f59f65d55bdf4 (diff)
downloadguix-ee448389cd3fb39f0f366bb71c6e9008b95ecb0a.tar
guix-ee448389cd3fb39f0f366bb71c6e9008b95ecb0a.tar.gz
gnu: Add ghc-tasty-expected-failure.
* gnu/packages/haskell-check.scm (ghc-tasty-expected-failure): New variable.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index e60bf46359..c7032097b2 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -311,6 +311,32 @@ only those tests that failed in the last run, or to only run the tests that have
been added since previous test run.")
(license license:bsd-3)))
+(define-public ghc-tasty-expected-failure
+ (package
+ (name "ghc-tasty-expected-failure")
+ (version "0.11.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "tasty-expected-failure/tasty-expected-failure-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0r555f18d2gj96pjyc13chn1nxaxl81am4xgip3mvvjhw8s5mva1"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-tagged" ,ghc-tagged)
+ ("ghc-tasty" ,ghc-tasty)))
+ (home-page "http://github.com/nomeata/tasty-expected-failure")
+ (synopsis "Mark tasty tests as failure expected")
+ (description
+ "With the function @code{Test.Tasty.ExpectedFailure.expectFail} in the
+provided module @code{Test.Tasty.ExpectedFailure}, you can mark that you
+expect test cases to fail, and not to pass. This can be used for test-driven
+development.")
+ (license license:expat)))
+
(define-public ghc-quickcheck-instances
(package
(name "ghc-quickcheck-instances")