aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-28 00:34:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-28 00:34:13 +0200
commite0b9e377f1822be434dc9eba516972979485694b (patch)
treebab3137a98d00f308a401095074829303f067059 /gnu/packages/guile.scm
parent201c0e72768fa92e2035512e16c17c07f308815b (diff)
parentfb2715720adfb770bccd37dd72b2bf1b0bc22e36 (diff)
downloadguix-e0b9e377f1822be434dc9eba516972979485694b.tar
guix-e0b9e377f1822be434dc9eba516972979485694b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0d1989e524..0297b9b21d 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1554,16 +1554,28 @@ is no support for parsing block and inline level HTML.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "04lgh0nk6ddnwgh20hnz4pyhczaik0xbd50kikjsxcwcl46shavb"))))
+ "04lgh0nk6ddnwgh20hnz4pyhczaik0xbd50kikjsxcwcl46shavb"))
+ (patches (search-patches "guile-bytestructures-name-clash.patch"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
#:builder
(begin
(use-modules (guix build utils)
+ (ice-9 ftw)
(ice-9 match)
(ice-9 popen)
(ice-9 rdelim))
+ ;; Unpack.
+ (setenv "PATH"
+ (string-join (list (assoc-ref %build-inputs "tar")
+ (assoc-ref %build-inputs "xz"))
+ "/bin:" 'suffix))
+ (system* "tar" "xf" (assoc-ref %build-inputs "source"))
+ (match (scandir ".")
+ (("." ".." directory)
+ (chdir directory)))
+
(let* ((out (assoc-ref %outputs "out"))
(guile (assoc-ref %build-inputs "guile"))
(effective (read-line
@@ -1572,7 +1584,7 @@ is no support for parsing block and inline level HTML.")
"-c" "(display (effective-version))")))
(module-dir (string-append out "/share/guile/site/"
effective))
- (source (assoc-ref %build-inputs "source"))
+ (source (getcwd))
(doc (string-append out "/share/doc/scheme-bytestructures"))
(sld-files (with-directory-excursion source
(find-files "bytestructures/r7" "\\.exports.sld$")))
@@ -1612,6 +1624,9 @@ is no support for parsing block and inline level HTML.")
;; Also copy over the README.
(install-file "README.md" doc)
#t))))
+ (native-inputs
+ `(("tar" ,tar)
+ ("xz" ,xz)))
(inputs
`(("guile" ,guile-2.2)))
(home-page "https://github.com/TaylanUB/scheme-bytestructures")
@@ -1624,6 +1639,9 @@ an abstraction over raw memory. It's also more powerful than the C
type system, elevating types to first-class status.")
(license license:gpl3+)))
+(define-public guile2.0-bytestructures
+ (package-for-guile-2.0 guile-bytestructures))
+
(define-public guile-aspell
(package
(name "guile-aspell")
@@ -1838,6 +1856,9 @@ is not available for Guile 2.0.")
manipulate repositories of the Git version control system.")
(license license:gpl3+))))
+(define-public guile2.0-git
+ (package-for-guile-2.0 guile-git))
+
(define-public guile-syntax-highlight
(let ((commit "a047675e66861b647426372aa2ba7820f749616d")
(revision "0"))