aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-09-08 19:43:41 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-10-03 19:32:50 +0530
commit658cc8b25f123c4c71d39fcd170d86b17c157516 (patch)
treee4cdc8c56da3c21bc818fe8d6dfc10b0272766ab /gnu/packages/guile-xyz.scm
parent362e33700d2fbb17a7435241858acb5375b78fbe (diff)
downloadguix-658cc8b25f123c4c71d39fcd170d86b17c157516.tar
guix-658cc8b25f123c4c71d39fcd170d86b17c157516.tar.gz
gnu: guile-dbi: Update to 2.1.8.
* gnu/packages/guile-xyz.scm (guile-dbi): Update to 2.1.8. [arguments]: Add chdir phase.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 66bcab099f..0363dd60c1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1518,7 +1518,7 @@ library}.")
(define-public guile-dbi
(package
(name "guile-dbi")
- (version "2.1.6")
+ (version "2.1.8")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1527,7 +1527,7 @@ library}.")
(file-name (git-file-name name version))
(sha256
(base32
- "0nswd067gvpy9pnig409ympkw29akh9lb2i6g3w7r18g1s0ivah2"))))
+ "123m4j82bi60s1v95pjh4djb7bh6zdwmljbpyg7zq8ni2gyal7lw"))))
(build-system gnu-build-system)
(arguments
`(#:modules (((guix build guile-build-system)
@@ -1541,6 +1541,11 @@ library}.")
(target-guile-effective-version (assoc-ref %build-inputs "guile"))))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ ;; The upstream Git repository contains all the code, so change
+ ;; to the directory specific to guile-dbi.
+ (chdir "guile-dbi")))
(add-after 'install 'patch-extension-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))