aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-12-16 23:14:56 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-12-16 23:14:56 -0500
commit17c3a3bfff150a42c904233fa39818d73c9f68f3 (patch)
treea7614b7cd9a7106ea59f5ac1caad0c2c496b3a45 /gnu/packages/guile-xyz.scm
parentf5493629e2650c0d30caf0f01f76b2383f78b9de (diff)
parentfe86819d8bde674766659c22b215d3a689a8026e (diff)
downloadguix-17c3a3bfff150a42c904233fa39818d73c9f68f3.tar
guix-17c3a3bfff150a42c904233fa39818d73c9f68f3.tar.gz
Merge branch 'master' into mesa-updates
Change-Id: I0c6e2410c51335c68634738be030e374f5b492e9
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm101
1 files changed, 61 insertions, 40 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 557589d2bb..fcaf788d37 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1103,6 +1103,35 @@ for calling methods on remote servers by exchanging JSON objects.")
(home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
(license license:expat)))
+(define-public guile-ares-rs
+ (package
+ (name "guile-ares-rs")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~abcdw/guile-ares-rs")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jl4k54ydi1qxdvif4di0ri5jznlfc2gg1qhs94bhk4y22k0gp8c"))))
+ (build-system guile-build-system)
+ (arguments
+ (list
+ #:source-directory "src"))
+ ;; Remove guile-next dependency, when guile package get custom text port
+ (inputs `(("guile" ,guile-next)))
+ (propagated-inputs (list guile-fibers))
+ (home-page "https://git.sr.ht/~abcdw/guile-ares-rs")
+ (synopsis "Asyncronous Reliable Extensible Sleek RPC Server for Guile")
+ (description "Asynchronous Reliable Extensible Sleek RPC Server for
+ Guile. It's based on nREPL protocol and can be used for programmable
+ interactions with a running guile processes, for implementing REPLs, IDEs,
+ test runners or other tools.")
+ (license license:gpl3+)))
+
(define-public guile-squee
(let ((commit "9f2609563fc53466e46d37c8d8d2fbcfce67b2ba")
(revision "5"))
@@ -3326,7 +3355,7 @@ from @code{tree-il}.")
(define-public guile-hoot
(package
(name "guile-hoot")
- (version "0.1.0")
+ (version "0.2.0")
(source (origin
(method url-fetch)
(uri (string-append "https://spritely.institute/files/releases"
@@ -3334,7 +3363,7 @@ from @code{tree-il}.")
version ".tar.gz"))
(sha256
(base32
- "1087rcj22hk6fcbqajm268f1q2c3kbizah8wy1z0aqkfliwc309g"))))
+ "1byshh7092q2yzqwpi59j4xjsppvp1xqnqsv94yv541qfm0plnc2"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0"
@@ -5408,49 +5437,41 @@ high-level API for network management that uses rtnetlink.")
(commit (string-append "v" version))))
(file-name (string-append name "-" version))
(sha256
- (base32
- "0srkmchd4kmfa7q65r6fdzwklhgdlck1ll0s7smzs8ddjdgz2lwm"))))
+ (base32 "0srkmchd4kmfa7q65r6fdzwklhgdlck1ll0s7smzs8ddjdgz2lwm"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
#:modules (((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%gnu-build-system-modules)
#:imported-modules ((guix build guile-build-system)
,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (guile-lib (assoc-ref inputs "guile-lib"))
- (json (assoc-ref inputs "guile-json"))
- (tls (assoc-ref inputs "guile-gnutls"))
- (version (target-guile-effective-version))
- (scm (string-append "/share/guile/site/"
- version))
- (go (string-append "/lib/guile/"
- version "/site-ccache")))
- (wrap-program (string-append bin "/gitlab-cli")
- `("GUILE_LOAD_PATH" prefix
- (,(string-append out scm)
- ,(string-append guile-lib scm)
- ,(string-append json scm)
- ,(string-append tls scm)))
- `("GUILE_LOAD_COMPILED_PATH" prefix
- (,(string-append out go)
- ,(string-append guile-lib go)
- ,(string-append json go)
- ,(string-append tls go))))))))))
- (native-inputs
- (list autoconf automake pkg-config texinfo))
- (inputs
- `(("bash" ,bash-minimal)
- ("guile" ,guile-2.2)
- ("guile-json" ,guile2.2-json)
- ("guile-lib" ,guile2.2-lib)
- ("guile-gnutls" ,guile2.2-gnutls)))
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile-lib (assoc-ref inputs "guile2.2-lib"))
+ (json (assoc-ref inputs "guile2.2-json"))
+ (tls (assoc-ref inputs "guile2.2-gnutls"))
+ (version (target-guile-effective-version))
+ (scm (string-append "/share/guile/site/" version))
+ (go (string-append "/lib/guile/" version
+ "/site-ccache")))
+ (wrap-program (string-append bin "/gitlab-cli")
+ `("GUILE_LOAD_PATH" prefix
+ (,(string-append out scm) ,(string-append
+ guile-lib scm)
+ ,(string-append json scm)
+ ,(string-append tls scm)))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
+ (,(string-append out go) ,(string-append guile-lib
+ go)
+ ,(string-append json go)
+ ,(string-append tls go))))))))))
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list bash-minimal guile-2.2 guile2.2-json guile2.2-lib
+ guile2.2-gnutls))
(home-page "https://github.com/artyom-poptsov/guile-gitlab")
(synopsis "Guile interface to GitLab")
(description
@@ -5462,7 +5483,7 @@ GitLab instance.")
(define-public guile-smc
(package
(name "guile-smc")
- (version "0.6.2")
+ (version "0.6.3")
(source
(origin
(method git-fetch)
@@ -5472,7 +5493,7 @@ GitLab instance.")
(file-name (string-append name "-" version))
(sha256
(base32
- "11083lj048ab5zsdgwpkshxi8v5nfdr7kvmmslszbi7lq2pwfqig"))))
+ "1gjwz1l2ls4xkkgg4d2vw3a1klc4var03ab4k6lq1jifdvc8n51f"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings