aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-04 15:18:11 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-04 23:54:15 +0100
commit475c3278df4f9dc1bc708e1092e8c93d0618711a (patch)
tree9060ca606223747b1a19b8dd71117e92adfe3954 /gnu/packages/guile-xyz.scm
parented2e0b1b50587a38ad26574585f73979874e56f0 (diff)
downloadguix-475c3278df4f9dc1bc708e1092e8c93d0618711a.tar
guix-475c3278df4f9dc1bc708e1092e8c93d0618711a.tar.gz
gnu: emacsy: Partially unbreak build and switch to Guile 3.0.
Previously it would fail to build. Now it fails tests. * gnu/packages/guile-xyz.scm (emacsy)[source]: Adjust 'uri'. Add 'snippet' and 'modules'. [native-inputs]: Remove AUTOCONF and AUTOMAKE. Replace GUILE-2.2 by GUILE-3.0. [inputs]: Replace GUILE-2.2 by GUILE-3.0.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm37
1 files changed, 27 insertions, 10 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2e8f6dc066..cfb6397c80 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
@@ -3078,18 +3078,35 @@ API.")
(version "0.4.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://download.savannah.nongnu.org/releases/"
- name "/" name "-" version ".tar.gz"))
+ (uri (string-append "mirror://savannah/emacsy/emacsy-"
+ version ".tar.gz"))
(sha256
(base32
- "1cpb85dl1nibd34c2x2h7vfmjpkgh353p5b1w20v6cs6gmvgg4np"))))
+ "1cpb85dl1nibd34c2x2h7vfmjpkgh353p5b1w20v6cs6gmvgg4np"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "configure"
+ ;; Allow builds with Guile 3.0.
+ (("2\\.2 2\\.0")
+ "3.0 2.2 2.0")
+
+ ;; Freeglut 3.2 provides 'glut.pc', not 'freeglut.pc'.
+ (("freeglut >= ")
+ "glut >= "))
+
+ (substitute* '("emacsy/emacsy.c"
+ "example/hello-emacsy.c")
+ (("#include <libguile\\.h>")
+ (string-append "#include <stdlib.h>\n"
+ "#include <stdio.h>\n"
+ "#include <string.h>\n"
+ "#include <unistd.h>\n"
+ "#include <libguile.h>\n")))))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bzip2" ,bzip2)
- ("guile" ,guile-2.2)
+ `(("bzip2" ,bzip2)
+ ("guile" ,guile-3.0)
("gettext" ,gettext-minimal)
("libtool" ,libtool)
("perl" ,perl)
@@ -3098,7 +3115,7 @@ API.")
("texlive" ,(texlive-union (list texlive-generic-epsf)))))
(inputs
`(("dbus-glib" ,dbus-glib)
- ("guile" ,guile-2.2)
+ ("guile" ,guile-3.0)
("guile-lib" ,guile-lib)
("guile-readline" ,guile-readline)
("freeglut" ,freeglut)