aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-10-26 01:39:27 +0100
committerRoel Janssen <roel@gnu.org>2020-10-26 08:49:13 +0100
commit22213308f3bcc41bd2356ccbb7350a74c1426a0a (patch)
treecfeb5340798768edd5311230c11feb334c912212 /gnu/packages/guile-xyz.scm
parent375ef50ce63c5ed552973cab3619d055d7b41b99 (diff)
downloadguix-22213308f3bcc41bd2356ccbb7350a74c1426a0a.tar
guix-22213308f3bcc41bd2356ccbb7350a74c1426a0a.tar.gz
gnu: guile-sparql: Update to 0.0.8.
* gnu/packages/guile-xyz.scm (guile-sparql): Update to 0.0.8. [arguments]: Enable tests. [inputs]: Switch to Guile 3.0. Signed-off-by: Roel Janssen <roel@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 88c0586dc9..6cdf3e1604 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1064,20 +1064,19 @@ allows users to interact with the Guile REPL through Jupyter.")
(define-public guile-sparql
(package
(name "guile-sparql")
- (version "0.0.7")
+ (version "0.0.8")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/roelj/guile-sparql/releases/download/"
version "/guile-sparql-" version ".tar.gz"))
(sha256
- (base32 "1drnvhsgl0gc5crmb16yyw1j98nkhwwcgssv9vgm36ng43nnzffd"))))
+ (base32 "1jf4972f9fpm0rd865xpnc9mzl3xv6vhfnp0iygadydy905z9nln"))))
(build-system gnu-build-system)
- (arguments `(#:tests? #f)) ; There are no tests.
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("guile" ,guile-2.2)))
+ `(("guile" ,guile-3.0)))
(home-page "https://github.com/roelj/guile-sparql")
(synopsis "SPARQL module for Guile")
(description "This package provides the functionality to query a SPARQL