aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-10 21:35:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-10 22:23:31 +0200
commitc2f93e9c07c75e47078ab313ce9e0c90ff130eb1 (patch)
treebd6bb94f4e764ab40fda86258b26f437974024da /gnu/packages/gstreamer.scm
parent1a1558e88f1f119be9dca28dac0bf554bc6aa171 (diff)
downloadguix-c2f93e9c07c75e47078ab313ce9e0c90ff130eb1.tar
guix-c2f93e9c07c75e47078ab313ce9e0c90ff130eb1.tar.gz
gnu: openjpeg: Update to 2.2.0 [security fixes].
In addition to the patches we already had (which are not mentioned in the ChangeLog, but verified by following their respective GitHub issues) this release also fixes CVE-2016-9112, CVE-2016-5139, CVE-2016-5152, CVE-2016-5158, CVE-2016-5159, CVE-2016-1626 and CVE-2016-1628. See <https://github.com/uclouvain/openjpeg/blob/v2.2.0/CHANGELOG.md> for details. * gnu/packages/patches/openjpeg-CVE-2016-9572-CVE-2016-9573.patch, gnu/packages/patches/openjpeg-CVE-2016-9850-CVE-2016-9851.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/image.scm (openjpeg): Update to 2.2.0. [source](patches): Remove. * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Add phase to patch hard-coded openjpeg-2.1 path.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 69b8ffabee..97fd52e160 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -275,7 +275,16 @@ developers consider to have good quality code and correct functionality.")
#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ "/share/gtk-doc/html"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-openjpeg-reference
+ (lambda _
+ ;; Remove hard-coded openjpeg-2.1 path. 2.2 is API- and
+ ;; ABI-compatible.
+ (substitute* "ext/openjpeg/gstopenjpeg.h"
+ (("<openjpeg-2\\.1/") "<openjpeg-2.2/"))
+ #t)))))
(propagated-inputs
`(("gst-plugins-base" ,gst-plugins-base)))
(native-inputs