aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-03-06 14:49:35 +0800
committer宋文武 <iyzsong@gmail.com>2016-03-07 09:57:20 +0800
commit201cfb81d112f98bb7240d5924fcab9fca955177 (patch)
treeba2ead18a13020e175dca5b6f1d97d3c9edbd753 /gnu/packages/gstreamer.scm
parentfa7cf82ebe5ca1516843e92fe63bcea863cf98a2 (diff)
downloadguix-201cfb81d112f98bb7240d5924fcab9fca955177.tar
guix-201cfb81d112f98bb7240d5924fcab9fca955177.tar.gz
gnu: Add gst-python.
* gnu/packages/gstreamer.scm (python-gst, python2-gst): New variables.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm54
1 files changed, 53 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 5b348b17f2..59b1076294 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -20,10 +20,11 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gstreamer)
- #:use-module ((guix licenses) #:select (lgpl2.0+ bsd-2 bsd-3 gpl2+))
+ #:use-module ((guix licenses) #:select (lgpl2.0+ lgpl2.1+ bsd-2 bsd-3 gpl2+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages audio)
#:use-module (gnu packages bison)
@@ -400,3 +401,54 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
"This GStreamer plugin supports a large number of audio and video
compression formats through the use of the libav library.")
(license gpl2+)))
+
+(define-public python-gst
+ (package
+ (name "python-gst")
+ (version "1.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/gst-python/"
+ "gst-python-" version ".tar.xz"))
+ (sha256
+ (base32
+ "09ci5zvr7lms7mvgbjgsjwaxcl4nq45n1g9pdwnqmx3rf0qkwxjf"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; XXX: Factorize python-sitedir with python-build-system.
+ `(#:imported-modules (,@%gnu-build-system-modules
+ (guix build python-build-system))
+ #:configure-flags
+ (let* ((python (assoc-ref %build-inputs "python"))
+ (python-version ((@@ (guix build python-build-system)
+ get-python-version)
+ python))
+ (python-sitedir (string-append
+ "lib/python" python-version "/site-packages")))
+ (list (string-append
+ "--with-pygi-overrides-dir=" %output "/" python-sitedir
+ "/gi/overrides")))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (propagated-inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("python-pygobject" ,python-pygobject)))
+ (home-page "http://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer GObject Introspection overrides for Python")
+ (description
+ "This package contains GObject Introspection overrides for Python that can
+be used by Python applications using GStreamer.")
+ (license lgpl2.1+)
+ (properties `((python2-variant . ,(delay python2-gst))))))
+
+(define-public python2-gst
+ (package (inherit python-gst)
+ (name "python2-gst")
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python-2)))
+ (propagated-inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("python-pygobject" ,python2-pygobject)))))