aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-22 20:12:52 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-22 20:12:52 +0200
commit119a749db9c9847e0766860c17109b0f0b6bf349 (patch)
tree4cdbfcad285124c1abf7b3c1c94666cef55767ce /gnu/packages/graph.scm
parent530d9e1555e8d0125dde6893f5f70c7a1ebc2564 (diff)
parent25669275a1a570cc266128274cb27a22f6a3a318 (diff)
downloadguix-119a749db9c9847e0766860c17109b0f0b6bf349.tar
guix-119a749db9c9847e0766860c17109b0f0b6bf349.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 683bfeec66..f91e81a30f 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -25,7 +25,9 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages bioinformatics)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
@@ -116,3 +118,31 @@ It can handle large graphs very well and provides functions for generating
random and regular graphs, graph visualization, centrality methods and much
more.")
(license license:gpl2+)))
+
+(define-public r-rgraphviz
+ (package
+ (name "r-rgraphviz")
+ (version "2.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Rgraphviz" version))
+ (sha256
+ (base32
+ "0mwdqsmmhpk8szp3pf3bw66nv2sazpjiflpwdvqwjamvxyynmp67"))))
+ (properties `((upstream-name . "Rgraphviz")))
+ (build-system r-build-system)
+ ;; FIXME: Rgraphviz bundles the sources of an older variant of
+ ;; graphviz. It does not build with the latest version of graphviz, so
+ ;; we do not add graphviz to the inputs.
+ (inputs `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-graph" ,r-graph)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://bioconductor.org/packages/Rgraphviz")
+ (synopsis "Plotting capabilities for R graph objects")
+ (description
+ "This package interfaces R with the graphviz library for plotting R graph
+objects from the @code{graph} package.")
+ (license license:epl1.0)))