aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-17 19:46:29 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-17 19:47:15 +0200
commitbf473f0ca0b218e9a93b00234a8f25ba015b8bd3 (patch)
tree5acb33bce3ee06276eb26a66dd8ab6429722448a /gnu/packages/graph.scm
parentf455d99dfaacd32411c224faa3020d594a7a24e9 (diff)
downloadguix-bf473f0ca0b218e9a93b00234a8f25ba015b8bd3.tar
guix-bf473f0ca0b218e9a93b00234a8f25ba015b8bd3.tar.gz
gnu: Add rw.
* gnu/packages/graph.scm (rw): New variable.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index abcb659456..8b06aaa0e9 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -476,3 +476,27 @@ isolating planarity obstructions.")
(license license:bsd-3)
(home-page
"https://github.com/graph-algorithms/edge-addition-planarity-suite")))
+
+(define-public rw
+ (package
+ (name "rw")
+ ;; There is a version 0.8, but the tarball is broken with symlinks
+ ;; to /usr/share.
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/rankwidth/"
+ "rw-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rv2v42x2506x7f10349m1wpmmfxrv9l032bkminni2gbip9cjg0"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("igraph" ,igraph)))
+ (home-page "https://sourceforge.net/projects/rankwidth/")
+ (synopsis "Rank-width and rank-decomposition of graphs")
+ (description "rw computes rank-width and rank-decompositions
+of graphs.")
+ (license license:gpl2+)))