aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2018-04-18 00:28:39 +0200
committerTomáš Čech <sleep_walker@gnu.org>2018-04-20 10:38:31 +0200
commite60352e4533a313a6fcbed615bd77729010b1968 (patch)
tree10687475671b0a5fdebe18e730697844de6619ef /gnu/packages/golang.scm
parent5368e67c4e86b7459c69675d237b356d3d1f7b1a (diff)
downloadguix-e60352e4533a313a6fcbed615bd77729010b1968.tar
guix-e60352e4533a313a6fcbed615bd77729010b1968.tar.gz
gnu: Add go-golang-org-x-crypto-ssh-terminal.
* gnu/packages/golang.scm (go-golang-org-x-crypto-ssh-terminal): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2fbd54a56..485aa02c46 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1257,3 +1258,43 @@ functions for normalizing Unicode strings.")
limiting in Go.")
(home-page "https://godoc.org/golang.org/x/time/rate")
(license license:bsd-3))))
+
+(define-public go-golang-org-x-crypto-ssh-terminal
+ (let ((commit "95a4943f35d008beabde8c11e5075a1b714e6419")
+ (revision "1"))
+ (package
+ (name "go-golang-org-x-crypto-ssh-terminal")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/crypto")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-crypto-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0bkm0jx9mxmi1liabb9c04kf765n7d0062zdp3zmvzyamsq00lcx"))))
+ (build-system go-build-system)
+ (inputs
+ `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (arguments
+ `(#:import-path "golang.org/x/crypto/ssh/terminal"
+ #:unpack-path "golang.org/x/crypto"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/golang.org/x/crypto/ed25519/testdata")
+ ".*\\.gz$"))
+ #t)))))
+ (synopsis "Terminal functions for Go")
+ (description "This package provides @{terminal}, which implements
+support functions for dealing with terminals, as commonly found on UNIX
+systems.")
+ (home-page "https://go.googlesource.com/crypto/")
+ (license license:bsd-3))))