aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-10-04 05:22:23 +0000
committerEfraim Flashner <efraim@flashner.co.il>2020-12-09 09:45:31 +0200
commitf7c2896e528fa5d1821eae36cc7d8e54d313daec (patch)
tree27327e600a87d759fe64325aefd767f07783ad53 /gnu/packages/golang.scm
parent2b0185a74bfae4adde46142ea0fc5fb02c4b1c4a (diff)
downloadguix-f7c2896e528fa5d1821eae36cc7d8e54d313daec.tar
guix-f7c2896e528fa5d1821eae36cc7d8e54d313daec.tar.gz
gnu: Add go-github-com-go-sql-driver-mysql.
* gnu/packages/golang.scm (go-github-com-go-sql-driver-mysql): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bacb835dec..12561c0a32 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3582,6 +3582,31 @@ without requiring a real database connection.")
(home-page "https://github.com/DATA-DOG/go-sqlmock")
(license license:expat))))
+(define-public go-github-com-go-sql-driver-mysql
+ (package
+ (name "go-github-com-go-sql-driver-mysql")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-sql-driver/mysql")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11x0m9yf3kdnf6981182r824psgxwfaqhn3x3in4yiidp0w0hk3v"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ;; tests require a network connection
+ #:import-path "github.com/go-sql-driver/mysql"))
+ (home-page "https://github.com/go-sql-driver/mysql")
+ (synopsis "MySQL driver for golang")
+ (description
+ "This is a pure Go implementaton of the MySQL API, compatible with
+golang's database/sql package.")
+ (license license:mpl2.0)))
+
(define-public go-golang-org-colorful
(package
(name "go-golang-org-colorful")