aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-07-21 17:17:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-07-21 17:56:44 +0300
commit504d5079d7dad26d6e26aefb3f7d039ba86b2b41 (patch)
tree29e901dd210325fdb51866dc3bb7d8bb20b8f28c /gnu/packages/golang-build.scm
parent971e874f4e7081d816bfbd2616e5bd84b3dfe5e1 (diff)
downloadguix-504d5079d7dad26d6e26aefb3f7d039ba86b2b41.tar
guix-504d5079d7dad26d6e26aefb3f7d039ba86b2b41.tar.gz
gnu: go-github-com-yuin-goldmark: Extend the test timeout.
* gnu/packages/golang-build.scm (go-github-com-yuin-goldmark) [arguments]: Adjust the custom 'check phase to also extend the test timeout to allow the tests to pass on slower machines. Change-Id: Iba98545b73a7fdd5c6c831069a5286521aeeceff
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index fbad61e269..d2ee54f021 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
-;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 HiPhish <hiphish@posteo.de>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
@@ -80,6 +80,10 @@
(replace 'check
(lambda* (#:key tests? import-path #:allow-other-keys)
(when tests?
+ ;; We need to extend the timeout on some architectures.
+ ;; 64 is the default in extra_test.go.
+ (setenv "GOLDMARK_TEST_TIMEOUT_MULTIPLIER"
+ (number->string (* 64 5)))
(with-directory-excursion (string-append "src/" import-path)
(invoke "go" "test" "-v" "./..."))))))))
(home-page "https://github.com/yuin/goldmark/")