aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-23 00:11:30 -0500
committerLeo Famulari <leo@famulari.name>2016-11-23 00:11:30 -0500
commitde76f0a45bad2654cc2561b463e3d6ec4d96c398 (patch)
treee1dcd0a33de2d8dffaa9d4c5068fc1fd0f149734 /gnu/packages/gnupg.scm
parentc70047f12d7e9d5138a1a217d0995882a8c5f459 (diff)
parent08b3e4a97066c9baaf39e3df7c2dd9c39e693ead (diff)
downloadguix-de76f0a45bad2654cc2561b463e3d6ec4d96c398.tar
guix-de76f0a45bad2654cc2561b463e3d6ec4d96c398.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 1f8ab21733..b0e59532c5 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -213,14 +213,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.1.15")
+ (version "2.1.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "1pgz02gd84ab94w4xdg67p9z8kvkyr9d523bvcxxd2hviwh1m362"))))
+ "0i483m9q032a0s50f1izb213g4h5i7pcgn395m6hvl3sg2kadfa9"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -245,8 +245,6 @@ compatible to GNU Pth.")
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "tests/openpgp/defs.inc"
- (("/bin/pwd") (which "pwd")))
(substitute* "scd/scdaemon.c"
(("\"(libpcsclite\\.so[^\"]*)\"" _ name)
(string-append "\"" (assoc-ref inputs "pcsc-lite")
@@ -256,13 +254,12 @@ compatible to GNU Pth.")
(lambda _
(substitute* (find-files "tests" ".\\.scm$")
(("/usr/bin/env gpgscm")
- (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
- (add-before 'check 'set-home
- ;; Some tests require write access to $HOME, otherwise leading to
- ;; 'failed to create directory /homeless-shelter/.asy' error.
- ;; TODO Try removing this phase for GnuPG 2.1.16.
+ (string-append (getcwd) "/tests/gpgscm/gpgscm")))
+ #t))
+ ;; If this variable is undefined, /bin/pwd is invoked.
+ (add-before 'check 'set-gnupg-home
(lambda _
- (setenv "HOME" "/tmp")
+ (setenv "GNUPGHOME" (getcwd))
#t)))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")