aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-09 22:39:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-09 22:39:26 +0300
commit9a53a79fc54e01932bd727ec519403ea4c2c3efc (patch)
tree61972203eec04b04d86a89414a633ca07b154b5d /gnu/packages/gnupg.scm
parent987f5acb2d13bf475b0c5bc6cf0ceea787fb1c20 (diff)
downloadguix-9a53a79fc54e01932bd727ec519403ea4c2c3efc.tar
guix-9a53a79fc54e01932bd727ec519403ea4c2c3efc.tar.gz
gnu: gnupg: Patch CVE-2022-34903.
* gnu/packages/gnupg.scm (gnupg)[replacement]: New field. (gnupg/replacement): New variable. * gnu/packages/patches/gnupg-CVE-2022-34903.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 08fa1570d6..90215a6877 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -285,6 +285,7 @@ compatible to GNU Pth.")
;; Note2: 2.2.33 currently suffers from regressions, so do not update to it
;; (see: https://dev.gnupg.org/T5742).
(version "2.2.32")
+ (replacement gnupg/fixed)
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-" version
@@ -352,6 +353,15 @@ libskba (working with X.509 certificates and CMS data).")
(properties '((ftp-server . "ftp.gnupg.org")
(ftp-directory . "/gcrypt/gnupg")))))
+(define gnupg/fixed
+ (package
+ (inherit gnupg)
+ (source (origin
+ (inherit (package-source gnupg))
+ (patches
+ (append (origin-patches (package-source gnupg))
+ (search-patches "gnupg-CVE-2022-34903.patch")))))))
+
(define-public gnupg-1
(package (inherit gnupg)
(version "1.4.23")