aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 09:06:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-11 09:06:02 +0300
commitb9fe72bf4d0e4911d7da5c0c126b41b58c4b37f0 (patch)
tree705671c5bce6fcad9ba725788534900862f91dbc /gnu/packages/gnunet.scm
parentc543b4e1d31372d8d43bdb4ffe65979ba2a62fe4 (diff)
downloadguix-b9fe72bf4d0e4911d7da5c0c126b41b58c4b37f0.tar
guix-b9fe72bf4d0e4911d7da5c0c126b41b58c4b37f0.tar.gz
gnu: gnurl: Use 'modify-phases'.
* gnu/packages/gnunet.scm (gnurl)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 60aa671c25..0083bf1fa6 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -193,12 +193,12 @@ and support for SSL3 and TLS.")
#:parallel-tests? #f
#:phases
;; We have to patch runtests.pl in tests/ directory
- (alist-cons-before
- 'check 'patch-runtests
- (lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh"))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-runtests
+ (lambda _
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
(description
"Gnurl is a microfork of cURL, a command line tool for transferring data