aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-23 11:29:33 +0000
committerLeo Famulari <leo@famulari.name>2016-12-23 11:58:03 -0500
commit50e9f81a221fc181a4e2e6918bc9c1e7c50619f8 (patch)
tree7ca33ad919a41fd49b4435f0fa265b27af452b2f /gnu/packages/gnunet.scm
parent4ec08b637b2dd636e0110b4d7dd88a4d14bdcc55 (diff)
downloadguix-50e9f81a221fc181a4e2e6918bc9c1e7c50619f8.tar
guix-50e9f81a221fc181a4e2e6918bc9c1e7c50619f8.tar.gz
gnu: gnurl: Split man pages to doc output.
* gnu/packages/gnunet.scm (gnurl)[arguments]: Add 'move-man3-pages' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 495a7de883..27e1ffb4e0 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -173,6 +173,8 @@ and support for SSL3 and TLS.")
(base32
"1gn6mvab2vhfj9637ykg1zjzb23fngfnyd24wlgxmjhf49pn334h"))))
(build-system gnu-build-system)
+ (outputs '("out"
+ "doc")) ; 1.5 MiB of man3 pages
(inputs `(("gnutls" ,gnutls)
("libidn" ,libidn)
("zlib" ,zlib)))
@@ -201,6 +203,15 @@ and support for SSL3 and TLS.")
#:phases
;; We have to patch runtests.pl in tests/ directory
(modify-phases %standard-phases
+ (add-after 'install 'move-man3-pages
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Move section 3 man pages to "doc".
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/man"))
+ (rename-file (string-append out "/share/man/man3")
+ (string-append doc "/share/man/man3"))
+ #t)))
(add-before 'configure 'autoconf
;; Clear artifacts left (shebangs) from release preparation.
(lambda _