aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-02-11 19:17:33 +0100
committerAndreas Enge <andreas@enge.fr>2014-02-11 19:44:48 +0100
commitb6b29c7737147bf683eb61bdbc93ad712a228ca7 (patch)
treeb3e9feaa3937a5f3b6f1ede7959fa3e9a509b56c /gnu/packages/gnunet.scm
parent1680df13a8449c38fa8ac0b31903c4bfaf6f6fde (diff)
downloadguix-b6b29c7737147bf683eb61bdbc93ad712a228ca7.tar
guix-b6b29c7737147bf683eb61bdbc93ad712a228ca7.tar.gz
gnu: curl, gnurl: Fix failing testcase 172.
* gnu/packages/patches/curl-fix-test172.patch: New file. * gnu-system.am (dist_patch_DATA): Add the patch file. * gnu/packages/gnunet.scm (gnurl): Apply the patch file. * gnu/packages/curl.scm (curl): Apply the patch file. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1529f96283..f3448a7e63 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -144,7 +144,10 @@ and support for SSL3 and TLS.")
version ".tar.bz2"))
(sha256
(base32
- "0kpi9wx9lg938b982smjg54acdwswdshs2bzf10sj5r6zmb05ygp"))))
+ "0kpi9wx9lg938b982smjg54acdwswdshs2bzf10sj5r6zmb05ygp"))
+ ;; This patch fixes testcase 172 which uses a hardcoded cookie
+ ;; expiration value which is expired as of Feb 1, 2014.
+ (patches (list (search-patch "curl-fix-test172.patch")))))
(build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls)
("libidn" ,libidn)