aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-02-10 23:44:57 +0100
committerAndreas Enge <andreas@enge.fr>2014-02-10 23:44:57 +0100
commit05e8a0b005ef865aa982387942953708168e14df (patch)
tree1b235ce6e6aa5b82a5511a41ec845d8d2a041e89 /gnu/packages/gnunet.scm
parent99fbddf9a623757e39d88bfb431f8f7d6f24b75b (diff)
downloadguix-05e8a0b005ef865aa982387942953708168e14df.tar
guix-05e8a0b005ef865aa982387942953708168e14df.tar.gz
gnu: gnunet: Add input libmicrohttpd.
* gnu/packages/gnunet.scm (gnunet): Add input libmicrohttpd and improve formatting.
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm40
1 files changed, 21 insertions, 19 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 2bbe72ffe1..39d0dbca9e 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -213,16 +214,17 @@ supports HTTPS, HTTPS and GnuTLS.")
(patch-flags '("-p0"))))
(build-system gnu-build-system)
(inputs
- `(("gnutls" ,gnutls)
- ("glpk" ,glpk)
+ `(("glpk" ,glpk)
+ ("gnurl" ,gnurl)
+ ("gnutls" ,gnutls)
("libextractor" ,libextractor)
("libgcrypt" ,libgcrypt)
- ("gnurl" ,gnurl)
("libidn" ,libidn)
+ ("libmicrohttpd" ,libmicrohttpd)
+ ("libtool" ,libtool)`
+ ("libunistring" ,libunistring)
("openssl" ,openssl)
("opus" ,opus)
- ("libtool" ,libtool)
- ("libunistring" ,libunistring)
("pulseaudio", pulseaudio)
("sqlite" ,sqlite)
("zlib" ,zlib)))
@@ -231,19 +233,19 @@ supports HTTPS, HTTPS and GnuTLS.")
("python" ,python-2)))
(arguments
'(#:phases
- ;; swap check and install phases and set paths to installed binaries
- (alist-cons-before
- 'check 'set-path-for-check
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "GNUNET_PREFIX" out)
- (setenv "PATH" (string-append (getenv "PATH") ":" out "/bin"))))
- (alist-cons-after
- 'install 'check
- (assoc-ref %standard-phases 'check)
- (alist-delete
- 'check
- %standard-phases)))))
+ ;; swap check and install phases and set paths to installed binaries
+ (alist-cons-before
+ 'check 'set-path-for-check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "GNUNET_PREFIX" out)
+ (setenv "PATH" (string-append (getenv "PATH") ":" out "/bin"))))
+ (alist-cons-after
+ 'install 'check
+ (assoc-ref %standard-phases 'check)
+ (alist-delete
+ 'check
+ %standard-phases)))))
(synopsis "Anonymous peer-to-peer file-sharing framework")
(description
"GNUnet is a framework for secure, peer-to-peer networking. It works in a