aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRene <pacoon@protonmail.com>2018-04-15 23:24:05 -0500
committerMarius Bakke <mbakke@fastmail.com>2018-04-17 00:37:27 +0200
commitfc5c5b92cf7a1f6d65079f3840df502edcf58f50 (patch)
tree3eee7ef64a6c7a28c413d69d4322eb21b6c787e3 /gnu/packages/gnome.scm
parent5849c68a3db4bcb646ea63204ae68946c49f3d4c (diff)
downloadguix-fc5c5b92cf7a1f6d65079f3840df502edcf58f50.tar
guix-fc5c5b92cf7a1f6d65079f3840df502edcf58f50.tar.gz
gnu: epiphany: Update to 3.28.1.
* gnu/packages/gnome.scm (epiphany): Update to 3.28.1. [build-system]: Use meson-build-system. [native-inputs]: Add desktop-file-utils, glib:bin and gtk+:bin. [inputs]: Add gdk-pixbuf+svg and nettle. Remove gdk-pixbuf. [arguments]: Remove #:configure-flags. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9145f62a8b..aac1f08978 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4166,7 +4166,7 @@ a secret password store, an adblocker, and a modern UI.")
(define-public epiphany
(package
(name "epiphany")
- (version "3.24.4")
+ (version "3.28.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4174,8 +4174,9 @@ a secret password store, an adblocker, and a modern UI.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1jg59s98aljf603w24r5a3cr4fw6z88gc0warqy1946iprjgdw0m"))))
- (build-system glib-or-gtk-build-system)
+ "0zvxrwlswxadq4zbr4f73ms141d08j0lhi6rzmj83j1s3gan88md"))))
+
+ (build-system meson-build-system)
(arguments
;; FIXME: tests run under Xvfb, but fail with:
;; /src/bookmarks/ephy-bookmarks/create:
@@ -4183,18 +4184,21 @@ a secret password store, an adblocker, and a modern UI.")
;; subsystem
;; FAIL
'(#:tests? #f
- #:configure-flags '("CFLAGS=-std=gnu99")))
+ #:glib-or-gtk? #t))
(propagated-inputs
`(("dconf" ,dconf)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("glib:bin" ,glib "bin") ; for glib-mkenums
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("intltool" ,intltool)
("itstool" ,itstool)
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)))
(inputs
`(("avahi" ,avahi)
("gcr" ,gcr)
- ("gdk-pixbuf" ,gdk-pixbuf) ; for loading SVG files
+ ("gdk-pixbuf+svg" ,gdk-pixbuf+svg) ; for loading SVG files
("glib-networking" ,glib-networking)
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
@@ -4203,6 +4207,7 @@ a secret password store, an adblocker, and a modern UI.")
("libnotify" ,libnotify)
("libsecret" ,libsecret)
("libxslt" ,libxslt)
+ ("nettle" ,nettle) ; for hogweed
("sqlite" ,sqlite)
("webkitgtk" ,webkitgtk)))
(home-page "https://wiki.gnome.org/Apps/Web")